Assigning an IP to Micrologix 1100. Is my PLC broken?

My PLC starts with no IP address. It shows the MAC address and then -.-.-.- for IP.

When I start BOOTP/DHCP server (on a computer connected via a crossover cable or via a switch), it sees the MAC address, but can’t assign an IP.


It says successfully sent the IP to the device, but it never registers. I have tried so many things, but just can’t get it to accept the IP address. Thoughts?


Once it shows that, the MicroLogix does not display the new address? Are you able to set it manually from the screen of the ML? Also, if all else fails, I’d try setting it up over RS232.

Hi Garet,
In particular, I recommend you follow the following steps:

  1. Once the fearful IP address was assigned to the PLC.
  2. You have to click to disable BOOTTP
  3. I recommend you verify the IP of your computer so that it is on the same network.
  4. That you open the cmd and do a continuous ping.
  5. For some equipment such as micro800 or IOpoint it is necessary to restart (turn off and turn on) the PLC to take the temporary IP.

Otherwise you will have to connect via serial.BOOTTP

Thanks for the suggestions and help. I ended up connecting via a serial cable and that solved the issue. Not sure why I wasn’t able to assign an IP directly, but serial worked and now an ethernet connection is all I need.