Issue with installing RSLogix Emulator

Hi everyone,

I have managed to download RSLogix and it works fine however I can’t seem to load the Emulator.

System Windows 10 x 64 bit.
Google Chrome Browser

I keep getting 2 errors.
![Screenshot 2022-09-12 180042|548x238](upload://oV5KsSAWuSv5IRWbvcXiAbVx0p4.png

The other error says: The RSLinx classic path was not found in ICOM.INI or ROCKSOFT.INI. RSLINX must be installed in order to run RSLogix Emulate 500.

I have looking for the rocksoft.ini file in the Rslogix folder in windows and it doesn’t appear to be there. I then noticed that when I am downloading it I get an error saying. RADAR manage download error.

I have tried loading it from Firefox, Troubleshooting and running it in all the previous versions of windows and installing the v12 files just in case.

Nothing seems to be working. I have tried uninstalling everything and trying again. Am I missing something obvious please?

Thanks in advance

1 Like

The Rocksoft.ini which is required by RSLogix Emulate 500 has incorrect information; or extra information. The Rocksoft.ini file is located in C:\Windows directory. Edit the file in Notepad and make sure that Path and RSLinx are as follows:

Below is an example of the contents of Rocksoft.ini file:

32 bit Operating Systems


Path=C:\Program Files\Rockwell software


RSLinx=C:\Program Files\Rockwell Software\RSLinx\RSLinx.exe

64 bit Operating Systems


Path=C:\Program Files (x86)\Rockwell software


RSLinx=C:\Program Files (x86)\Rockwell Software\RSLinx\RSLinx.exe

1 Like